Vote for BP.Net for the 2013 Forum of the Year! Click here for more info.

» Site Navigation

» Home
 > FAQ

» Online Users: 346

16 members and 330 guests
Most users ever online was 3,642, 05-08-2016 at 08:50 AM.


» Today's Birthdays

» Stats

Members: 64,356
Threads: 238,682
Posts: 2,479,529
Top Poster: JLC (31,652)
Welcome to our newest member, Emeraldsserpent
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    BPnet Veteran cletus's Avatar
    Join Date
    08-26-2016
    Location
    San Antonio, TX
    Posts
    1,927
    Thanks
    1,705
    Thanked 1,552 Times in 1,042 Posts
    Images: 55
    I've never found any hitchhikers in my Reptichip..

  2. #12
    Registered User Bogertophis's Avatar
    Join Date
    04-28-2018
    Location
    USA
    Posts
    7,187
    Thanks
    9,879
    Thanked 5,529 Times in 3,521 Posts

    Re: Found this insect in my substrate

    Quote Originally Posted by cletus View Post
    I've never found any hitchhikers in my Reptichip..
    Sorry, you didn't "win" any prizes...

  3. The Following User Says Thank You to Bogertophis For This Useful Post:

    cletus (02-09-2019)

  4. #13
    BPnet Veteran cletus's Avatar
    Join Date
    08-26-2016
    Location
    San Antonio, TX
    Posts
    1,927
    Thanks
    1,705
    Thanked 1,552 Times in 1,042 Posts
    Images: 55

    Re: Found this insect in my substrate

    Quote Originally Posted by Bogertophis View Post
    Sorry, you didn't "win" any prizes...
    Damitt I've bought enough of it Why not???

  5. #14
    Registered User Bogertophis's Avatar
    Join Date
    04-28-2018
    Location
    USA
    Posts
    7,187
    Thanks
    9,879
    Thanked 5,529 Times in 3,521 Posts

    Re: Found this insect in my substrate

    Quote Originally Posted by cletus View Post
    Damitt I've bought enough of it Why not???
    Guessing your "luck" is as rotten as mine?
    Last edited by Bogertophis; 02-09-2019 at 12:15 AM.

  6. The Following User Says Thank You to Bogertophis For This Useful Post:

    cletus (02-09-2019)

  7. #15
    BPnet Lifer Zincubus's Avatar
    Join Date
    02-22-2011
    Posts
    5,229
    Thanks
    2,030
    Thanked 3,149 Times in 2,023 Posts

    Re: Found this insect in my substrate

    Quote Originally Posted by Bogertophis View Post
    Must be the token "lucky beetle" then?
    It's probably Ringo ... bad luck


    Sent from my iPhone using Tapatalk




  8. The Following User Says Thank You to Zincubus For This Useful Post:

    e_nigma (02-09-2019)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.1