Vote for BP.Net for the 2013 Forum of the Year! Click here for more info.

» Site Navigation

» Home
 > FAQ

» Online Users: 381

11 members and 370 guests
Most users ever online was 3,642, 05-08-2016 at 08:50 AM.


» Today's Birthdays

None

» Stats

Members: 64,659
Threads: 239,163
Posts: 2,484,731
Top Poster: JLC (31,652)
Welcome to our newest member, Atomixus
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Registered User ckuhn003's Avatar
    Join Date
    07-18-2017
    Location
    Georgia
    Posts
    797
    Thanks
    410
    Thanked 492 Times in 285 Posts
    Images: 2

    Found this insect in my substrate

    Any idea what this bug is and how he might of got in my substrate? I lifted my BOAs hide and found him in the Reptichip.




    Sent from my iPhone using Tapatalk
    1.0 Toffino - (Fred)

    1.0 Super Ghost BCI - (Phantom)

    1.0 Boxer - (Cooper)

  2. #2
    Registered User Jellybeans's Avatar
    Join Date
    12-08-2018
    Location
    Houston, TX
    Posts
    1,559
    Thanks
    34
    Thanked 646 Times in 427 Posts

    Re: Found this insect in my substrate

    Idk maybe some kind of beetle

    Sent from my LGMP260 using Tapatalk

  3. #3
    Registered User Bogertophis's Avatar
    Join Date
    04-28-2018
    Location
    USA
    Posts
    7,801
    Thanks
    10,764
    Thanked 6,040 Times in 3,843 Posts
    Looks vaguely familiar....what is the actual length?

  4. #4
    Registered User Luvyna's Avatar
    Join Date
    01-06-2019
    Posts
    307
    Thanks
    348
    Thanked 236 Times in 147 Posts
    Don't know what these are called but they look very similar to a kind of bug I see a lot in parks and playgrounds with wood chips.

  5. The Following User Says Thank You to Luvyna For This Useful Post:

    Bogertophis (02-08-2019)

  6. #5
    Registered User Treeman's Avatar
    Join Date
    01-26-2019
    Posts
    153
    Thanks
    16
    Thanked 123 Times in 78 Posts

    Re: Found this insect in my substrate

    Have you introduced any wood, branches, leaf litter, etc. that you have gathered from outside that mightíve brought it in? Or added anything new recently to the enclosure?


    Sent from my iPhone using Tapatalk

  7. #6
    Registered User Bogertophis's Avatar
    Join Date
    04-28-2018
    Location
    USA
    Posts
    7,801
    Thanks
    10,764
    Thanked 6,040 Times in 3,843 Posts

    Re: Found this insect in my substrate

    Quote Originally Posted by Luvyna View Post
    Don't know what these are called but they look very similar to a kind of bug I see a lot in parks and playgrounds with wood chips.
    I agree...I was thinking I've seen them in my yard...or something very similar. I have big trees, ground cover, grass, mulch, raised beds, moss, you-name-it...
    I'm no expert on insects, but I'm thinking it might morph into some kind of beetle?
    Last edited by Bogertophis; 02-08-2019 at 07:36 PM.

  8. #7
    Registered User ckuhn003's Avatar
    Join Date
    07-18-2017
    Location
    Georgia
    Posts
    797
    Thanks
    410
    Thanked 492 Times in 285 Posts
    Images: 2

    Re: Found this insect in my substrate

    The bug was about the size of my thumbnail. Nothing from the outside was introduced into the enclosure like branches, etc...

    My Reptichip substrate has been in there for months. I've been doing just spot cleaning here and there. Hopefully this was an isolated incident.
    1.0 Toffino - (Fred)

    1.0 Super Ghost BCI - (Phantom)

    1.0 Boxer - (Cooper)

  9. #8
    Registered User MarkL1561's Avatar
    Join Date
    01-31-2015
    Posts
    199
    Thanks
    274
    Thanked 297 Times in 109 Posts

    Re: Found this insect in my substrate

    Looks like some kind of fungus beetle. I recently used reptichip too and thankfully I didnít find any bugs. I did have to pull out plastic though. I wasnít overly impressed with reptichip, kritter krumble on Amazon is better imo.


    Sent from my iPhone using Tapatalk

  10. The Following User Says Thank You to MarkL1561 For This Useful Post:

    Bogertophis (02-08-2019)

  11. #9
    Registered User Jbabycsx's Avatar
    Join Date
    10-07-2018
    Posts
    413
    Thanks
    214
    Thanked 385 Times in 192 Posts

    Re: Found this insect in my substrate

    Iíve found one beetle in mine as well.


    Sent from my iPhone using Tapatalk

  12. The Following User Says Thank You to Jbabycsx For This Useful Post:

    Bogertophis (02-08-2019)

  13. #10
    Registered User Bogertophis's Avatar
    Join Date
    04-28-2018
    Location
    USA
    Posts
    7,801
    Thanks
    10,764
    Thanked 6,040 Times in 3,843 Posts
    Must be the token "lucky beetle" then?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.1